導航:首頁 > 軟體知識 > 如何編寫月線粘合的程序

如何編寫月線粘合的程序

發布時間:2024-07-09 08:38:26

A. 求均線粘合選股指標! 求月線,周線.日線,均線粘合或者將要粘合的選股指標!謝謝各位!!

所謂的均線粘合就是5、10、20、30、60、90、120、250日中有兩條或三條、四條、五條、六條移動平均成本接近相同,或相差不大。例如三線粘合,我們只需要比較出這三條線中的最大成本和最小成本,把最大成本值和最小成本值之間的差距定義為某一個窄幅波動范圍就可以了。可以隨意修改參數。

參數名 最小 最大 預設
M1 0.00 1000.00 5.00
M2 0.00 1000.00 10.00
M3 0.00 1000.00 20.00
M4 0.00 1000.00 60.00
M5 0.00 1000.00 120.00
M6 0.00 1000.00 250.00

A:MAX(MAX(MA(CLOSE,M1),MA(CLOSE,M2)),MA(CLOSE,M3)),LINETHICK0;
B:MIN(MIN(MA(CLOSE,M1),MA(CLOSE,M2)),MA(CLOSE,M3)),LINETHICK0;
三線粘合:IF(RANGE(100*(A-B)/B,0,5),100*(A-B)/B,DRAWNULL),LINETHICK0;
SA:MAX(MAX(MA(CLOSE,M1),MA(CLOSE,M2)),MAX(MA(CLOSE,M3),MA(CLOSE,M4))),LINETHICK0;
SB:MIN(MIN(MA(CLOSE,M1),MA(CLOSE,M2)),MIN(MA(CLOSE,M3),MA(CLOSE,M4))),LINETHICK0;
四線粘合:IF(RANGE(100*(SA-SB)/SB,0,10),100*(SA-SB)/SB,DRAWNULL),LINETHICK0;
WA:MAX((MAX(MA(CLOSE,M1),MA(CLOSE,M2)),MAX(MA(CLOSE,M3),MA(CLOSE,M4))),MA(CLOSE,M5)),LINETHICK0;
WB:MIN((MIN(MA(CLOSE,M1),MA(CLOSE,M2)),MIN(MA(CLOSE,M3),MA(CLOSE,M4))),MA(CLOSE,M5)),LINETHICK0;
五線粘合:IF(RANGE(100*(WA-WB)/WB,0,15),100*(WA-WB)/WB,DRAWNULL),LINETHICK0;
LA:MAX((MAX(MA(CLOSE,M1),MA(CLOSE,M2)),MAX(MA(CLOSE,M3),MA(CLOSE,M4))),MAX(MA(CLOSE,M5),MA(CLOSE,M6))),LINETHICK0;
LB:MIN((MIN(MA(CLOSE,M1),MA(CLOSE,M2)),MIN(MA(CLOSE,M3),MA(CLOSE,M4))),MIN(MA(CLOSE,M5),MA(CLOSE,M6))),LINETHICK0;
六線粘合:IF(RANGE(100*(LA-LB)/LB,0,20),100*(LA-LB)/LB,DRAWNULL),LINETHICK0;

B. 我用通達信編了一個均線粘合的選股公式:可是怎麼選都選不出來那些均系粘合的股票

均線粘合選股公式

MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA30:=MA(C,30);

MAX_MA:=MAX(MA5,MAX(MA10,MAX(MA20,MA30)));
MIN_MA:=MIN(MA5,MIN(MA10,MIN(MA20,MA30)));

粘合度:=(MAX_MA-MIN_MA)/MIN_MA*100;

角度MA5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;
角度MA10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
角度MA20:=ATAN((MA20/REF(MA20,1)-1)*100)*180/3.1416;
角度MA30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;

X1:=粘合度<=5;
X2:=角度MA5>0 AND 角度MA10>0 AND 角度MA20>0;
X3:=C>MA5 AND MA5>MA10 AND MA10>MA20 AND V/MA(V,5)>1.5;
XG:X1 AND X2 AND X3;
從網上搜出來的,粘合本來就不太好量化,選不出來只是閾值的關系,是正常的。

C. 鑲$エ鍧囩嚎5錛10,20涓夌嚎鍚堜竴 瑕佺矘鍚堝湪涓璧 灝介噺紕板埌鐨 榪欐牱鐨勫叕寮忔庝箞緙栵紵

鑲$エ鍧囩嚎5錛10錛20涓夌嚎鍚堜竴錛岃佺矘鍚堝湪涓璧鳳紝灝介噺紕板埌鐨勶紝閭d箞鍏寮忓氨鏄疢A5:=MA(C錛5);MA10:=MA(C錛10);MA20:=MA(C錛20);A1:=ABS(MA5-MA10)/C*100<0.5;A2:=ABS(MA10-MA20)/C*100<0.5;A3:=ABS(MA5-MA20)/C*100<0.5;A5:=MA5>REF(MA5錛1)+0.01;XG:A1 AND A2 AND A3 AND A5;
5鏃ャ10鏃ャ20鏃ヤ笁鏉″潎綰誇氦奼囨椂褰㈡垚涓涓鍏辨尟鐐癸紝姝ゅ叡鎸鐐圭殑鍚戜笂鎴栧悜涓嬫柟鍚戝彉鍖栫О涓虹煭綰跨殑鏈浣充拱鐐瑰拰鍗栫偣銆傚潎綰跨殑璧板鉤浠h〃浜嗗嵆灝嗗嚭鐜伴噸瑕佺殑鏂瑰悜閫夋嫨銆傚綋鍧囩嚎鐢卞師鏉ヨ繍鍔ㄦ柟鍚戣漿涓鴻蛋騫籌紝甯傚満緇忚繃涓孌墊椂闂寸殑闇囪崱鐩樻暣錛屼細閫夋嫨鍐嶆″悜涓婃垨鍚戜笅鐨勮繍琛屾柟鍚戱紝鎻愬墠鐩稿規湁鏁堝湴鍒ゆ柇鍑哄叾榪愯屾柟鍚戞槸鍧囩嚎搴旂敤涓鐨勪竴涓閲嶇偣銆
鎷撳睍璧勬枡
鑲$エ錛坰tock錛夋槸鑲′喚鍏鍙告墍鏈夋潈鐨勪竴閮ㄥ垎錛屼篃鏄鍙戣岀殑鎵鏈夋潈鍑璇侊紝鏄鑲′喚鍏鍙鎬負絳歸泦璧勯噾鑰屽彂琛岀粰鍚勪釜鑲′笢浣滀負鎸佽偂鍑璇佸苟鍊熶互鍙栧緱鑲℃伅鍜岀孩鍒╃殑涓縐嶆湁浠瘋瘉鍒搞傝偂紲ㄦ槸璧勬湰甯傚満鐨勯暱鏈熶俊鐢ㄥ伐鍏鳳紝鍙浠ヨ漿璁╋紝涔板崠錛岃偂涓滃嚟鍊熷畠鍙浠ュ垎浜鍏鍙哥殑鍒╂鼎錛屼絾涔熻佹壙鎷呭叕鍙歌繍浣滈敊璇鎵甯︽潵鐨勯庨櫓銆傛瘡鑲¤偂紲ㄩ兘浠h〃鑲′笢瀵逛紒涓氭嫢鏈変竴涓鍩烘湰鍗曚綅鐨勬墍鏈夋潈銆傛瘡瀹朵笂甯傚叕鍙擱兘浼氬彂琛岃偂紲ㄣ
鍚屼竴綾誨埆鐨勬瘡涓浠借偂紲ㄦ墍浠h〃鐨勫叕鍙告墍鏈夋潈鏄鐩哥瓑鐨勩傛瘡涓鑲′笢鎵鎷ユ湁鐨勫叕鍙告墍鏈夋潈浠介濈殑澶у皬錛屽彇鍐充簬鍏舵寔鏈夌殑鑲$エ鏁伴噺鍗犲叕鍙告昏偂鏈鐨勬瘮閲嶃
鑲$エ鏄鑲′喚鍏鍙歌祫鏈鐨勬瀯鎴愰儴鍒嗭紝鍙浠ヨ漿璁┿佷拱鍗栵紝鏄璧勬湰甯傚満鐨勪富瑕侀暱鏈熶俊鐢ㄥ伐鍏鳳紝浣嗕笉鑳借佹眰鍏鍙歌繑榪樺叾鍑鴻祫銆
鑲$エ鏄涓縐嶆湁浠瘋瘉鍒革紝鏄鑲′喚鍏鍙稿湪絳歸泦璧勬湰鏃跺悜鍑鴻祫浜哄彂琛岀殑鑲′喚鍑璇侊紝浠h〃鐫鍏舵寔鏈夎咃紙鍗寵偂涓滐級瀵硅偂浠藉叕鍙哥殑鎵鏈夋潈錛岃喘涔拌偂紲ㄤ篃鏄璐涔頒紒涓氱敓鎰忕殑涓閮ㄥ垎錛屽嵆鍙鍜屼紒涓氬叡鍚屾垚闀垮彂灞曘
榪欑嶆墍鏈夋潈涓轟竴縐嶇患鍚堟潈鍒╋紝濡傚弬鍔犺偂涓滃ぇ浼氥佹姇紲ㄨ〃鍐熾佸弬涓庡叕鍙哥殑閲嶅ぇ鍐崇瓥銆佹敹鍙栬偂鎮鎴栧垎浜綰㈠埄宸浠風瓑錛屼絾涔熻佸叡鍚屾壙鎷呭叕鍙歌繍浣滈敊璇鎵甯︽潵鐨勯庨櫓銆傝幏鍙栫粡甯告ф敹鍏ユ槸鎶曡祫鑰呰喘涔拌偂紲ㄧ殑閲嶈佸師鍥犱箣涓錛屽垎綰㈡淳鎮鏄鑲$エ鎶曡祫鑰呯粡甯告ф敹鍏ョ殑涓昏佹潵婧愩

閱讀全文

與如何編寫月線粘合的程序相關的資料

熱點內容
mysql怎麼切換資料庫 瀏覽:154
支付寶小程序怎麼開啟許可權 瀏覽:291
如何進入信息社會 瀏覽:393
誅仙端游怎麼交易 瀏覽:667
貴溪到南昌鋼材市場坐什麼車 瀏覽:442
做點什麼微商代理最賺錢 瀏覽:355
遙控技術原理屬於什麼學科 瀏覽:544
車子違章信息哪裡查 瀏覽:2
為什麼網店代理要交預存款 瀏覽:615
有哪些發布兼職信息的公眾號 瀏覽:866
市場上泡水車有多少 瀏覽:653
如何按順序對比兩欄的數據 瀏覽:721
二手房交易糾紛如何申請仲裁 瀏覽:61
如何查詢自己的股東信息 瀏覽:66
如何更新股票信息 瀏覽:147
營口招聘市場前景如何 瀏覽:310
升學e網通怎麼填寫個人信息 瀏覽:447
打工仔可以學習什麼技術 瀏覽:261
你們能在一起多久小程序 瀏覽:465
sod因子的產品有哪些 瀏覽:30